Jump to Navigation

Common Issues with EDA Tools on Ubuntu 14.04 LTS

PlanAhead Segfault:

When trying to run PlanAhead you may get the following error:
/opt/Xilinx/14.5/ISE_DS/PlanAhead/bin/rdiArgs.sh: line 95: 31921 Segmentation fault      (core dumped) "$RDI_PROG" "$@"

This seems to be an issue with the packaged libjvm.so library, more information can be found at the following links:
http://forums.xilinx.com/t5/Installation-and-Licensing/RHEL5-64-bit-ISE-...
https://wiki.archlinux.org/index.php/Xilinx_ISE_WebPACK

So to fix it, do the following:
sudo apt-get install openjdk-7-jre
cd $XILINX/../PlanAhead/tps/lnx64/jre/lib/amd64/server
sudo mv libjvm.so libjvm.so.backup
sudo ln -s /usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/server/libjvm.so libjvm.so

If you have this problem with the lab installation of PlanAhead, please contact Dr. Athanas

 

Modelsim:

Setup a modelsim startup script with the following contents:
export PATH=/opt/system/software/Mentor/modeltech/linux:$PATH
export MODELSIM=~/modelsim.ini #otherwise it tries to write to /opt/system/ and fails
source ~/xilinx64.sh #sources settings64.sh from $XILINX

If using a 64-bit version of Ubuntu, you will need the following 32-bit libraries:
sudo apt-get install libc6:i386 libx11-6:i386 libxext6:i386 libxft2:i386 libncurses5:i386

You may encounter the following error: ** Fatal: Read failure in vlm process
The fix for this error can be found here:
http://mattaw.blogspot.com/2014/05/making-modelsim-altera-starter-editio...

Now run the vsim command to start modelsim.  You will need to run the compxlib command for your appropriate version of the Xilinx ISE tools if you haven't already.

 



Main menu 2

Book | by Dr. Radut